I suggest that the OWLR app...

Connect using HTTPS

I do not see it clearly anywhere, but the feature to use HTTPS instead of HTTP would be great.

160 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    justin shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    37 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Billy commented  ·   ·  Flag as inappropriate

        I've test all that procédures for Android, but it's not working!

        When i monitor traffic on my router, only http is used.

        I can't beleve that this security major leak is not covered !
        All your admin credentials are in clear over the internet.

        It should be the first feature to develop!

      • Aids10 commented  ·   ·  Flag as inappropriate

        Procedure to force settings to work:

        only workaround I could find to get all cameras to connect!

        add camera Manually-
        enter int. ip
        http port (actual)
        streaming port (actual)
        remote
        enter ext. host
        http port (actual)

        go into cameras network settings
        change Internal streaming port to your httpS port
        app will then add secure port automatically!

        note- with older cams this adds the secure port but removes the streaming (doesn't matter)

        hope this helps someone else, as app should force manual settings...

      • Aids10 commented  ·   ·  Flag as inappropriate

        Solution:

        my older foscams don't need streaming port (optional)
        menu view and live view still work correctly

        with my newer foscams I entered the streaming port (rtsp)
        and now live view works

        also noticed that if I go back into settings and change my streaming port to my HTTPS port;
        the app automatically created a new row SECURE port and updated streaming port automatically too!!!

        app seems to have buggy network settings...

        remote connection now works with all three ports now showing up in settings!

      • Aids10 commented  ·   ·  Flag as inappropriate

        Update:

        While doing below first gave me a successful "test external access" when I tried connecting remotely it would not connect.

        Now when I go back into app test results are negative.

        I'm using my Foscam DDNS hostname, which works perfectly through web.

        Definitely, an issue with the selection of HTTPS protocol!

      • Aids10 commented  ·   ·  Flag as inappropriate

        Same, I could not manually add hostname & HTTPS port (cannot input protocol)

        Solution (android):

        First manually add (locally) with IP & HTTP port.

        Then add your remote hostname in settings (no protocol but with httpS port)

      • Anonymous commented  ·   ·  Flag as inappropriate

        +1 for this, and more pointedly an indication of current status of connection etc.

      • Johnny O commented  ·   ·  Flag as inappropriate

        Cannot access my camera outside home wifi network. Any suggestions? Really pointless if I can't receive alerts and view live feed. Otherwise it's going bye bye.

      ← Previous 1

      Feedback and Knowledge Base